PowerShell 5.0

Sep 9, 2016 at 12:53 PM
Hello

The PSPKI Module was installed on a Windows Server 2012 R2, with PowerShell 5.0.

PSPKI Module only can used with PowerShell 3.0?


PS C:\Windows\system32> Get-CertificationAuthority
Get-CertificationAuthority : The term 'Get-CertificationAuthority' is not recognized as the name of a cmdlet,
function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the
path is correct and try again.
At line:1 char:1
  • Get-CertificationAuthority
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : ObjectNotFound: (Get-CertificationAuthority:String) [], CommandNotFoundException
    • FullyQualifiedErrorId : CommandNotFoundException
Best Regards
Coordinator
Sep 11, 2016 at 7:17 PM
Two questions:
  1. did you install server component of the module?
  2. did you import the module?
PSPKI works on PowerShell 3.0 and newer. PowerShell 5.0 is supported.