Start-Job Error

Dec 1, 2013 at 9:07 AM
PS C:> 10.100.11.23 | start-job {Test-WebServerSSL} -InitializationScript {Import-Module PSPKI}

PS C:> Import-Module : The current Windows PowerShell host is: 'ServerRemote
Host' (version 1.0.0.0). The module
'C:\Windows\system32\WindowsPowerShell\v1.0\Modules\PSPKI\PSPKI.psd1' requires a minimum Windows PowerShell host
version of '2.0' to run.
At line:1 char:1
  • Import-Module PSPKI
  • ~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : ResourceUnavailable: (C:\Windows\syst...SPKI\PSPKI.psd1:String) [Import-Module], Invalid
      OperationException
    • FullyQualifiedErrorId : Modules_InsufficientPowerShellHostVersion,Microsoft.PowerShell.Commands.ImportModuleCommand
I've tried with "-PSVersion 2.0 & 3.0" - same error. Thanks for the help.
Coordinator
Dec 1, 2013 at 9:14 AM
Currently the module cannot be executed in the remoting sessions. However, it is reasonable to add the remoting support for commands that access local resources only.
Coordinator
Dec 1, 2013 at 9:14 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.