Error occured while running Import-Module PSPKI

Sep 21, 2012 at 5:55 AM

Hi,

After installing the PS PKI v2.0.exe I ran the Import-Module PSPKI command. But I keep getting the following error,


PS C:\Windows\system32> import-module PSPKI
Write-ErrorMessage : Exception of type 'Microsoft.PowerShell.Commands.WriteErrorException' was thrown.
At C:\Users\...\Documents\WindowsPowerShell\Modules\PSPKI\PSPKI.psm1:117 char:26
+ catch {Write-ErrorMessage <<<<  -Source "CAPIUnavailable"}
    + CategoryInfo          : NotImplemented: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : NotImplementedException,Write-ErrorMessage

What shall I do to overcome this issue?

Thank you.

Coordinator
Sep 21, 2012 at 10:58 AM

Hi, it looks like you haven't installed ADCS RSAT tools. If you are using client operating system, install RSAT, if you are using server OS, add required RSAT components in Server Manager.

Sep 24, 2012 at 8:07 AM

Hi,

That solved my problem.

Thank you.

Coordinator
Sep 24, 2012 at 8:38 AM

Enjoy ADCS automation with Windows PowerShel!